
Changes in CabWriter Version 2.0.6 April 5, 2019 

New Functionality 

 

Fixes 

1. Fixed an issue where the Template drop down in the LayOut Document SetUp dialog box pointed to 

LayOut 2018 Templates regardless of SketchUp version the user was using. 

2. Fixed a problem where combo drawers would always be drawn as a solid, regardless of drawer 

height. 

3. Fixed a problem where combo draws drawn in frame and panel would be left as a group instead of 

individual frame and panel components. 

4. Fixed an issue with CabWriter Production Documentation. If a model’s file name is the same as the 

folder’s name it resides in, and the Project name are all the same, an error would be raised with the 

message “The requested file is locked or in use by another application”. 

  



Changes in CabWriter Version 2.0.5 3-11-2019 

New Functionality 

 

Fixes 

1. Fixed a problem that occurred frequently with models using inset joinery. The problem occurred 

seldom on models that did not use inset joinery, though it sometimes could. The typical error 

message was "The model appears to contain a component with a missing face.". 

2. Fixed a problem that restricted DXF output to 100” (2540 mm) long sheet goods. Now the user’s 

model can call for 150” (3810 mm) long sheet goods. This is intended to allow use of 12 foot sheet 

goods or its metric equivalent. 

3. After and error message, SketchUp was sometimes left in a state that required a tool such as the 

Line tool to be used before the Select tool could be chosen. Now, after an error message, the Select 

tool is automatically chosen. 

  



Changes in CabWriter Version 2.0.4 2-20-2019 

New Functionality 

 

Fixes 

4. CabWriter Software LLC’s website is now a secure site. Hence its new URL is 

https://www.cabwritersoftware.com/. This change required a code change because it produced 

errors when trying to activate a license. 

  

https://www.cabwritersoftware.com/


Changes in CabWriter Version 2.0.3 2-12-2019 

New Functionality 

 

Fixes 

1. Disconnected the Offset input field in the Divided Base Options and Divided Upper Options sections 

of the Box Selector and Modify Box Selector dialog boxes from Mid-Stretchers. Also rename Offset 

to Fixed Shelf Offset. The result is that Fixed Shelf Offset only applies to Fixed Shelf(s), not to Mid-

Stretchers. This solved a problem with pockets being drawn incorrectly in upper divided cabinets 

and the mid-stretchers being placed incorrectly in both base and upper cabinets. 

 

In addition, changed the Component Type for Fixed Shelf from Bottom to Shelf, which changes its 

CutList Bridge attribute. Lastly, on the CNC Setup tab, changed the default Shelf/Fixed Shelf in the 

CNC Milled Faces section from Bottom to Top. These two changes permitted the correct DXF 

drawing of mid-stretchers; specifically it permitted the drawing of the rabbets on the tongues. 

2. Fixed a problem with the Insert a Drawer tool. If the top rail is drawn, and the user tries to insert a 

drawer that touches the top rail, the drawer opening is incorrectly calculated, making the selected 

drawer box height less than it should be. 

3. Fixed a problem with Edit Cabinet. If, for example, a Standard Base w/Drawers is drawn with two 

doors and two drawers, and subsequently the Edit Cabinet tool is used to edit another aspect of the 

cabinet, the doors and drawers would revert to one door and one drawer, even though these 

parameters were not changed. This was due to the asynchronous nature of the HTMLDialog causing 

a code race condition. 

4. Fixed a problem with an uninitialized class instance variable. If the user just completed editing a 

divided upper cabinet using Edit Cabinet, and followed that by editing any non-divided upper 

cabinet also using Edit Cabinet, any box number greater than 1 would be interpreted as a divided 

upper even though its DNA says otherwise. 

5. Fixed a problem with Divided Upper and Divided Base where the wrong set of defaults could get 

selected when using the Insert a Door tool. This would only occur when the selected rectangle 

touched more than one box and when the user was queried about the wrong box first. 

6. Fixed a problem where drawer boxes in a Divided Upper were mistakenly placed on the Upper 

Drawer Fronts layer instead of the Upper Drawer Boxes layer. 

  



Changes in CabWriter Version 2.0.2 Release 12-26-2018 

New Functionality 

 

Fixes 

1. Made changes to satisfy compatibility with SketchUp 2019 Ruby Interpreter 2.5.1. 

2. Changed the cursor icons to be compatible with very large screen resolutions. 

3. Fixed a problem which raised an error when 

dadoes are used (vs qualified tenons). The 

problem is actually a SketchUp bug, but I 

coded a work around. This problem occurs if 

the user selects Inset for Construction Method 

and the Pocket Width is greater than 

approximately ½ the Top, Bottom, Stretcher 

or Fixed Shelf thickness. See image at right. 

 

This workaround, unfortunately, can cover up 

a real problem, so when it occurs the user will 

be given a warning message instructing the 

user to check the affected components to see 

if the problem is real or a SketchUp created 

problem. The latter requires no fix on the part 

of the user. The former would require a 

drawing change in component edit mode. The warning message will look like the image at the 

top of the next page, along with its associated Ruby Console list. 

4. Fixed a problem where hinge plate holes were placed too low on the side(s) of a Divided Upper 

by the amount of Bottom Inset. 

5. Fixed a problem where the user couldn’t change the width of bottom rails in upper doors using 

the Bottom Rail Width default in the Upper Doors Frame & Panel section of the Doors tab. The 

bottom rail for upper doors was tied to the top rail for upper doors default. 

6. Converted all of the CabWriter Settings dialog boxes (tabs) to be compatible with SketchUp’s 

Ruby API  UI::HtmlDialog class. Thirteen dialog boxes have been converted; only 17 more to go. 

;<) 

7. Fixed a problem where, when drawing a base bottom tongue, a condition for the tongue was 

tied to the wrong default: inset_sides_and_bottom instead of inset_sides_and_top. 

8. Fixed a problem where, when drawing a tongue using pushpull, unnecessary faces and edges 

where left in the component, making it a simple component, not a solid component. This would 

cause extraneous rectangles being drawn in the DXF files. 

  



 

9. Fixed a problem with context menu CabWriter > Edit Cabinet and the Edit Cabinet tool. A 

cabinet could be edited one time successfully. But if you tried to edit it again, without closing 

SketchUp, no changes would be accepted. 

10. Converted Box Selector and Modify Box Selector dialog boxes to be compatible with SketchUp’s 

Ruby API  UI::HtmlDialog class. Fifteen dialog boxes have been converted; only 15 more to go. 

;<) 

11. Fixed a problem where Component Type on the Attributes tab of Extended Entity info would be 

cleared if you selected (checked) Swap L/W?. 

12. Fixed a problem where under certain conditions Re-Number Cabinet would not re-number the 

target cabinet. 

13. Fixed a bug that was introduced when Box Selector and Modify Box Selector dialog boxes where 

changed to HtmlDialog class in 10 above. Divided cabinets (base and Upper) with more than one 

box raised an error. 

14. Fixed several of the Imperial and Metric “canned” defaults which had the incorrect Minimum 

Frame & Panel Drawer Height: in the Base Frame & Panel & Divided Upper Frame & Panel  

sections of the Drawers tab. These incorrect defaults would result in an error such as below 

right. 

15. Provided error handling for situations 

were a model may have a corrupted 

or unintended component which is 

missing a face. The user will now get a 

message “The model appears to 

contain a component with a missing 

face.”. 



 

 

Changes in CabWriter Version 2.0.1 Release 10-24-2018 

New Functionality 

No new functionality in this release. 

Fixes 

1. DXF functionality was not available to 30-Day Trial users. It is now available while operating on 

the 30-Day clock. 

2. When using slab doors and end sheet stiles that are drawn, selecting a miter joint had no effect; 

you would always get a butt joint. 

3. When drawing upper cabinets with a stile not drawn, and when using Cabinet Style Face Frame / 

Hybrid, the doors did not extend to within a clearance of the side’s outer edge. 

4. Fixed a problem where materials that were not assigned a hatch pattern could create an error 

when the command Hatch Sections in LayOut was used. 

5. Fixed a CutList Bridge DXF bug. When Extended Entity Info attributes Swap L/W and CabWriter 

Cabinet/Resize Mode were both set, Swap L/W was ignored. Note: Swap L/W and Enable Auto 

Swap? Can never be set at the same time. 

6. Fixed a problem where if the characters skp were in a file name or Project Name (CabWriter 

Settings Project tab), and the user tried to export a cut list, an error called “The requested file is 

locked or in use by another application.” was raised. 

7. Fixed a problem with divided upper and divided base cabinets. If either of these cabinets are 

drawn with no Divided Base Options chosen (in the Box Selector dialog box), AND a Back 

Attachment Method of other than Planted is chosen (Carcass tab, Back section), an error is 

raised. 

 

  



Changes in CabWriter Version 2.0.0 Release 7-30-2018 

New Functionality 

 

Fixes 

1. On the upper Box Selector I corrected the naming of the Divided Base Options to Divided Upper 

Options. 

2. Fixed a problem with frameless cabinets that had a top mid-stretcher. The drawing would not 

complete. 

3. The CabWriter Imperial defaults files included a file called Framless which is misspelled and has 

some incorrect defaults. Fixed the defaults and saved it as Frameless. 

4. Fixed a problem with Insert a Door. This must have been a problem accidentally introduced in a 

recent change, because it worked in the past and code was actually missing. 

5. Changed the File > CabWriter > Save Defaults to File > CabWriter > Save CabWriter Defaults to 

agree with the tool icon tooltip. Also, made this command available in the Home edition. 

6. Included the CabWriter 2 with CutList Bridge DXF.pdf user’s guide in the installation file. 

7. Added a command to the Extensions > CabWriter sub-menu called Open User’s Guide. 

CabWriter 2 with CutList Bridge DXF.pdf can now be accessed with Extensions > CabWriter > 

Open User’s Guide or with the Open User’s Guide button on the Setup tab of the Extended 

Entity Info dialog box. 

8. Disabled the DXF by Material Name & Thickness checkbox and CutList Plus fx with DXF radio 

button in the Select Desired Reports section of the Production Documentation dialog box when 

the product ID is NOT either CNC or EDC. I.e., a CNC license. 

9. Changed the license checking to accept either a version 1 or version 2 license. 

10. Fixed an issue where the Extensions > CabWriter menu was no longer available after a 

Extensions > CabWriter > Remove License command. Now it is available as long as CabWriter is 

installed. 

11. Disabled File > CabWriter to Layout for SketchUp versions older than 2018, or when the license 

is a HOME edition. 

12. Fixed a problem with Divided Upper which had no bottom rail and a drawer was drawn at the 

bottom. The drawer positioning and drawer slide holes were misplaced, in addition to the 

drawer box height being too large. 

13. Fixed a similar problem with the Divided Base which had no bottom rail and a bottom inset. 

14. Fixed a problem where the DXF export check-box could be set even on installations with only 

Home or Pro licenses. 

15. Enabled the File > CabWriter Production Documentation command on the Home license. 

 

  



Changes in CabWriter Version 2.0.0 6-22-2018 

New Functionality 

None. 

Fixes 

1. Fixed the Drawer Box Depth table, on the Drawers tab, for Metric default files, to include Metric mm 

in the Drawer Depth and Description fields. Prior to this change drawer boxes would be drawn but 

would be very shallow in depth. See changes below. 

 

 

2. Fixed a problem where user drawn circular pocket (holes with depths less than the thickness of the 

material) were placed on an Inside Profile DXF layer with a depth of cut equal to the thickness of the 

material. Circular Pockets are now placed on a Pockets layer with a depth equal to the drawn depth, 

as they should be. 

3. The Imperial default files were all missing a Carcass material name. Added Maple Plywood - Pre-

Finished. 

  



Changes in CabWriter Version 2.0.0 Beta 6-7-2018 

New Functionality 

  

1. Added Metric defaults to the CabWriter Defaults 

factory install folder. Imperial defaults are stored 

in: 

Plugins\cabwriter\cabwriter_defaults\imperial 

and Metric defaults are stored in: 

Plugins\cabwriter\cabwriter_defaults\metric 

 

Be sure that the Model Info dialog box, Unit page, 

has the correct Format and Precision for the 

defaults you choose. For example, if you choose 

an Imperial defaults file you should choose a 

Fractional Format and a 1/64” Precision. If you 

choose a Metric defaults file you should choose a 

Decimal Format and 0.00mm Precision (do not 

choose 0.0mm because rounding may cause 

problems with this precision. 

2. Also changed the Defaults File Selector dialog box to reflect the new folder locations. See image 

above. 

Fixes 

1. Fixed the Red/Green lights on the Face Frame tab of CabWriter Settings. When in 

Decimal/Metric mode the lights could appear red even though the results column show a zero 

difference. 

2. Fixed a problem where some on-edge rectangles were not extended off-edge during the 

generation of DXF files. 

  



Changes in CabWriter Version 2.0.0 Beta 5-31-2018 

Release Summary 

This beta release had a purpose; to implement dado, grove and rabbet construction methods, along 

with the associated DXF features, to provide full support for both inside and outside profile and pocket 

cuts on the CNC as well as drilling. 

New Features: 

1. Dado, rabbet, and tongue and groove construction for carcasses, including both stopped and 

through, including fixed shelves.  Includes qualified dado and rabbet construction. Captured backs 

will also be supported. 

2. Automatic detection of user added cutouts and drill holes.  These features will be added to the DXF 

according to a new layer structure defined below. 

3. Ability to specify a single DXF file per part as well as the current system of including all parts of 

similar material in one file. 

New DXF Layer Naming: 

Many CAM software packages have the ability to automatically create tool paths based on the layer 

name, but each of the packages uses a different format for layer names.  CabWriter now provides the 

ability for the user to customize the layer names by filling in a table with their preferred names.  Since 

the layer name can include parameters such as depth, drill bit size, or even material thickness, a facility 

is provided to include those parameters in the layer name using strings and drop down boxes. 

Layer names are defined by six strings concatenated together. Strings are contained within 

curly braces {  }, but are not part of the layer name, as shown below. Refer to the CNC Setup 

tab for this example. 

{Prefix 1}{Variable 1}{Prefix 2}{Variable 2}{Prefix 3}{Variable 3} 

The resulting layer name for shelf holes would be: 

drill_t5mm_d0.5_n5mm_drill 

If a hole is found to be the diameter of a drill bit in the Drill Bit Table section it will be placed on 

the Drill layer with a name defined by the Layer Type – Drill. In this case Prefix 1 is {drill_t}. 

Variable 1 is set to Diameter, so CabWriter substitutes the Diameter of 5mm, because shelf 

holes are set at 5mm and this diameter is found in the Drill 1 row of the Drill Bit Table. Hence 

Variable 1 is {5mm}. Prefix 2 for the Drill Layer Type is {_d}, which stands for depth of the hole. 

Hence Variable 2 will be {0.5} because shelf holes are drilled ½” deep. Prefix 3 for the Drill layer 

is {_n} for name. Lastly, Variable 3 is set to Name and the name shown for Drill 1 is 5mm_drill or 

{5mm_drill}. Putting all the strings together in order gives us: 

{drill_t}{5mm}{_d}{0.5}{_n}{5mm_drill} 

Or, because the curly braces are not included in the layer name: 



drill_t5mm_d0.5_n5mm_drill 

CabWriter will examine all holes, dadoes, groves, rabbets and cutouts to see if they fall in a 

Layer Type of: 

• Drill 

• Small Outside Profile 

• Large Outside Profile 

• Inside Profile 

• Pocket 

Drill Layer 

There will be one Drill Layer for each unique hole diameter/depth combination as long as the 

hole diameter matches an entry in the Drill Bit Table; if the hole diameter does not match 

anything in the table, it will be considered a Pocket Layer or Inside Profile Layer, depending on 

its depth.  The drill table is a three entry table that will contain the exact diameter of the drill bits 

supported by the users CNC as well as a string representing the name as it is in the users CAM 

software.  The exact string that is entered in the table will be used as the label for the diameter 

in the layer name.  The CabWriter detected depth will be used as the depth in the layer name. 

CabWriter will permit three different drill bits to be defined in the Drill Bit Table. The number of 

different drill layer names could be large because for each drill diameter there could be multiple 

drill depths. 

Note: The drill layer name should always include at least the drill diameter and depth or it will 

not be possible to differentiate between different hole sizes and depths. 

Small Outside Profile 

The Small Outside Profile Layer is used only for outside perimeter cuts on small CabWriter parts. 

Small parts are those whose area is equal to or smaller than that specified by default CNC 

Small Part in the General section of the CNC Setup tab. CabWriter permits one outside profile 

cutting bit to be specified in the Cutting Bit Table. This same bit is used for both large and small 

part cuts. 

Large Outside Profile 

The Large Outside Profile Layer is used only for outside perimeter cuts on large (normal) 

CabWriter parts. Large parts are those whose area is larger than that specified by default CNC 

Small Part in the General section of the CNC Setup tab. CabWriter permits one outside profile 

cutting bit to be specified in the Cutting Bit Table. This same bit is used for both large and small 

part cuts. 

Inside Profile 

The Inside Profile Layer is for the cutouts on the interior of parts.  Note: If CabWriter detects a hole 

(circle) on a part that goes all the way through and it’s diameter does not match an entry in the drill 

table, it will be considered an inside profile and added to this layer. Inside Profiles are simply cutouts 

such as those for obstructions, plumbing and electrical fixtures. CabWriter permits one inside profile 

cutting bit to be specified in the Cutting Bit Table. 



Pocket 

The Pocket Layer is for cutouts on the interior of parts that do not go all the way through to the other 

side. This includes interior pockets of any shape, dados, rabbets, tongues, grooves, etc. 

The geometry will be defined by the shape of the pocket cut into the material either by CabWriter when 

drawing the cabinet, or by the user after the cabinet is drawn.  In the case of a pocket that runs off the 

material in the case of a rabbet or dado/groove, for example, CabWriter will need to create a rectangle 

that extends past each edge that the pocket exits a distance equal to half the diameter of the cutting bit 

that will be used as specified in the cutting bit table. CabWriter permits one pocket cutting bit to be 

specified in the Cutting Bit Table. 

Labels 

The Labels Layer is used to place a part’s number and name on. The user can change the tag ‘Labels’, but 

whatever the name it will always contain the each part’s number and name.   



New Functionality 

1. Made major changes to the CabWriter Settings in preparation for dado, grove and rabbet joinery 

and CNC cutting. The number of tabs went from 11 to 12 with the addition of a CNC Setup tab. The 

Project tab, shown below, has a slightly larger Project Description area and the CNC Small Part 

default has been removed from this tab and placed on the new CNC Setup tab. 

 

 

The Carcass tab has also changed; mostly a labeling change, however, one default parameter has 

been added, called Pocket Depth. This default is in the section now called Top/Bottom/Stretcher 

Joinery. See the top of the next page. 

 

The CNC Boring tab lost its DXF Layers section. They are now on the new CNC Setup tab and have 

new names and functionality. See the bottom of the next page and the top of the page after that. 

 

 

  



 

 

 



 

Carcass Tab – General Section Defaults (Refer to the Carcass tab image.) 

 There has been one default added to the General section: Tongue Clearance applies to all 

tongues resulting from defaults in the Back or Top/Bottom/Stretcher Joinery sections. It is a dimension 

subtracted from tongues’ nominal depth in order to keep them from bottoming out in the groove or 

pocket. 

Parameter Name Possible Values Default Comments 

Top/Bottom/Stretcher 
Recess 

Positive dimension. 0” Top, bottom and stretchers, including 
mid-stretchers, can be recessed from the 
front edge of the sides as specified by this 
parameter. 

Tongue Clearance 
(Applies if an Inset value is 
chosen for Back Attachment 
Method or Inset is selected for 
Construction Method.) 

Positive dimension. 1/32” This defines how much shorter a tongue 
is from its nominal receiving groove or 
pocket depth. Only valid if captured in a 
groove, actual size if it’s a rabbeted back. 

 

Carcass Tab – Back Section Defaults (Refer to the Carcass tab image.) 

 The defaults changed in this release fall into two sections of the Carcass tab: the Back section 

which deals with the joinery of the back to the carcass; and the Top/Bottom/Stretcher Joinery section 

which deals with the joinery of the top, bottom or stretchers to the sides of the carcass. Below is a 

description of the Back section defaults:  



Parameter Name Possible Values Default Comments 

Back Attachment 
Method 

• Planted 

• Inset Full 

• Inset Sides Only 

• Inset Sides/Top 

• Inset Sides/Bottom 

Planted Inset can be manipulated to be either 
captured in a groove or inset into a 
rabbet. 
Inset Full - Groove in top, stretchers, 
sides and bottom 
Inset Sides Only - Groove in sides only, 
top and bottom butt into back. 
Inset Sides/Top - Groove in sides and 
top/stretcher only.  Bottom butts into the 
back. 
Inset Sides/Bottom - Groove in sides and 
bottom only.  Top or back stretcher butts 
into the back. 

Carcass Grove Width 
(Applies only if an Inset value is 
chosen for Back Attachment 
Method.) 

Positive dimension. 

3/8” 

If the groove width is the same or greater 
than the thickness of the back, then it's 
inset into a rabbet.  The Carcass Back 
Groove Inset Distance would also have to 
be set properly. 

Carcass Grove Depth 
(Applies only if an Inset value is 
chosen for Back Attachment 
Method.) 

Positive dimension. 

3/8” 

Note:  The corresponding tongue length 
is assumed to be the same as the groove 
depth.  Clearance is provided by the Back 
Clearance parameter 

Carcass Grove Inset 
Distance 
(Applies only if an Inset value is 
chosen for Back Attachment 
Method.) 

Must be at least the 
thickness of the carcass 
back. 

1/2” 

The distance from the back edge of the 
cabinet to where the carcass back groove 
starts if an Inset mode is selected.  If 
Carcass Groove Width is set to a distance 
greater than the thickness of the back 
material then this parameter indicates 
how far the back is inset into the cabinet 
and thereby dictates the width of the 
rabbet. 

 

Refer to the drawing at the top of the next page for more information. 



 

 

 

  



Carcass Tab – Top/Bottom/Stretcher Joinery Section Defaults (Refer to the Carcass tab image.) 

The Top/Bottom/Stretcher Joinery section deals with the joinery of the top, bottom or stretchers to the 

sides of the carcass. Its defaults are described below: 

Parameter Name Possible Values Default Comments 

Construction Method • Butt Joint 

• Inset 

Butt 
Joint 

Tongue and groove or rabbet for top, 
bottom & stretchers and dado for fixed 
shelves can be specified for Inset 
construction using the following defaults. 

Pocket Front Setback 
(Applies only if Inset value is 
chosen for Construction 
Method.) 

Must be a positive 
distance value. 

0” 

This allows you to create a stopped dado, 
rabbet, or groove.  Zero indicates no 
setback so the pocket goes all the way to 
the front edge.  A positive number 
indicates how far back the pocket starts 
from the front edge of the carcass part.  
The Pocket Bit Diameter (see CNC Setup 
tab Cutting Bit Table section) also comes 
into play here because if there is a 
setback, the rectangle on the DXF needs 
to extend past the end of the stopped 
dado by 1/2 the cutter diameter. 

Pocket Rear Setback 
(Applies only if Inset value is 
chosen for Construction 
Method.) 

Must be a positive 
distance value. 

0” 

This allows you to create a stopped dado, 
rabbet, or groove.  Zero indicates no 
setback so the pocket goes all the way to 
the back edge.  A positive number 
indicates how far back the pocket starts 
from the back edge of the carcass part.  
The Pocket Bit Diameter (see CNC Setup 
tab Cutting Bit Table section) also comes 
into play here because if there is a 
setback, the rectangle on the DXF needs 
to extend past the end of the stopped 
dado by 1/2 the cutter diameter. 

  



Parameter Name Possible Values Default Comments 

Pocket Width 
(Applies only if Inset value is 
chosen for Construction 
Method.) 

Positive dimension. 

1/2” 

A pocket could be a groove, dado, or 
rabbet.  
• Width is 3/4", for example, if 
bottom/top thickness is 3/4" and you 
want a rabbet for top/stretchers and 
bottom, and dados for fixed shelves. 
• Specify less than 3/4" if you wanted a 
tongue and groove situation.  So, if this 
parameter is less than the thickness of 
the part that is being inserted, then it 
becomes a tongue and groove.   
• Joinery Fit Compensation is always 
taken into account when something has 
to fit into a groove or dado. 
• If this value is greater than the nominal 
thickness of the plywood, it is ignored 
and the nominal thickness is used.  

Pocket Depth 
(Applies only if Inset value is 
chosen for Construction 
Method.) 

Positive dimension. 

3/8” 

Indicates the depth of the pocket, if one is 
used.  The length of the tongue would be the 
same as the depth of the pocket + Joinery Fit 
Compensation (see CNC Setup tab General 
section). 

 

CNC Setup Tab – Drill Bit Table (Refer to the CNC Setup tab image.) 

The Drill Bit Table permits the specifying of three drill bits. These are string fields so they will appear in 

the various Drill Layer names just as they appear in the table. It is recommended not to use special 

characters unless necessary. CabWriter cannot assure that all CNC manufacturers software will accept 

special characters without creating problems. Whenever possible, use the CNC software vendors 

definitions for drill bit names and formats for diameter. 

CNC Setup Tab - Cutting Bit Table (Refer to the CNC Setup tab image.) 

The Cutting Bit Table permits the specifying of one cutting bit for each of the Outside Profile, Inside 

Profile and Pocket cuts. These are string fields so they will appear in the various layer names just as they 

appear in the table. It is recommended not to use special characters unless necessary. CabWriter cannot 

assure that all CNC manufacturers software will accept special characters without creating problems. 

Whenever possible, use the CNC software vendors definitions for cutting bit names and formats for 

diameter. 

CNC Setup Tab – DXF Layers (Refer to the CNC Setup tab image.) 

The DXF Layers section permits the customization of DXF layer names. This can be very useful if the CNC 

software vendor uses layer names for tool pathing. Each Layer Type, with the exception of Labels, has six 

string fields that can be customized; three fields labeled Prefix are strings that the user can completely 

customize and three fields called Variable are drop down selectable and CabWriter will supply the 

appropriate string. Note that any Prefix can be left blank and hence no characters added to the layer 



name. Each drop down also has a blank selection and no characters will be added to the layer name. If 

all fields are blank the layer name will default to the Layer Type name. These are string fields so they will 

appear in the various layer names just as they appear in the table. It is recommended not to use special 

characters unless necessary. CabWriter cannot assure that all CNC manufacturers software will accept 

special characters without creating problems. Whenever possible, use the CNC software vendors 

definitions for layer names. 

CNC Setup Tab – General (Refer to the CNC Setup tab image.) 

The General section has only one default described below. 

Parameter Name Possible Values Default Comments 

CNC Small Part (Units are 

Area) 
 

100 

Specifies the area of the maximum size small 
part. Parts larger in area than this are 
considered large (normal) parts.  The units 
will depend on SketchUp’s Model Info dialog 
box, Units page, Format setting. If Inches, the 
area will be considered sq. in. If mm it will be 
considered sq. mm.  

 

CNC Setup Tab – CNC Milled Faces (Refer to the CNC Setup tab image.) 

There are construction choices that produce components with dadoes, rabbets or pockets on both sides. 

Because of the nature of CNC machines, both sides cannot be milled; parts cannot be flipped over and 

re-aligned. The designer has to choose the preferred side for milling on the CNC. The CNC Milled Faces 

section provides that ability. The following table explains the Component Type(s) and Milled Face 

defaults found in this section. See number 7 below for where on the Component Type is specified. 

Component Type Options Default 

Sides Inside:Outside Inside 

Top/Stretchers Inside:Outside Outside 

Bottom Inside:Outside Outside 

Shelf/Fixed Shelf Top:Bottom Bottom 

Back Inside:Outside Outside 

Custom Left:Right:Front:Back:Top:Bottom Left 

 

Inside:Outside is determined by a face on the inside of a cabinet's box, or the outside of a cabinet's box. 

Left:Right has a red axis normal and Left is the lowest R value and Right the highest R value. 

Front:Back has a green axis normal and Back is the lowest G value and Front the highest G value. 

Top:Bottom has a blue axis normal and Bottom is the lowest B value and Top the highest B value. 

 

2. Implemented captured backs for all cabinets except Diagonal Corner and Lazy Susan cabinets. Those 

cabinets also cannot be constructed with captured sides. Cabinets drawn with backs captured with a 

tongue and groove, shown above, make use of a default called Back Clearance. This keeps the 

tongue from bottoming out and preventing the sides, top and bottom from reaching the height and 



width dimensions, while also allowing the back to aid in squaring the cabinet. Backs captured in a 

rabbet ignore this parameter. In addition to the image at the top of the next page, see the images 3 

pages back. 

3. Implemented inset construction method for all cabinets except Diagonal Corner and Lazy Susan 

cabinets when captured sides is chose. Captured sides is not permissible on these cabinets 

regardless of construction method. 

4. Added ability for the user to define where user CabWriter defaults files are stored. This will permit 

installing new versions of CabWriter without losing user saved defaults. CabWriter factory supplied 

defaults are still stored in the same place: 

 

Plugins\cabwriter\cabwriter_defaults 

 

However, user saved defaults will no longer be stored here. Instead they will be saved in a directory 

defined by the user, which can be done in one of three ways: 



a) On the Project tab of CabWriter Settings, below the Walls section, is a new section called User 

Default Files. The input filed will be blank until the user specifies a default directory. To do this 

click on the folder icon to the right and select a directory using the Select Folder dialog box. This 

should be done as soon as a CabWriter project is created. But this is not a project only default; it 

is a CabWriter wide default that will be available from project to project until again changed by 

the user. So it only has to be specified one time. 

 

b) If the default directory has not yet been specified at the time the user selects the Save 

CabWriter Defaults tool, the Select Folder dialog box will automatically open and the user can 

specify the default directory and then save the defaults in it. 

c) If the default directory has not yet been specified at the time the user selects the Open and 

Load CabWriter Defaults tool, the Select Folder dialog box will automatically open and the user 

can specify the default directory and then choose a file to open. 

In all three cases the defaults directory will be set and appear in the User Default Files section each 

time the Project tab is opened. The Open and Load CabWriter Defaults tool opens the Defaults File 

Selector dialog box, which now also has a different look, shown below. 

 

 

Notice you can select defaults factory supplied by CabWriter, or defaults saved by the user. With the 

release of CabWriter 2.0 there will be a number of factory supplied defaults to choose from. These 

will hopefully include a set of Metric defaults in addition to Imperial defaults. They should serve as a 

good starting point for users, but can be customized and saved as user defaults. 



5. Added ability for the user to define where CutList Bridge materials backup 

files are stored. This will permit installing new versions of CabWriter 

without losing backed-up materials files. CutList Bridge factory supplied 

materials files are still stored in the same place: 

 

Plugins\cabwriter\cutlist_bridge\cutlist_bridge\text_files 

 

However, user backed-up materials files will no longer be stored here. 

Instead they will be saved in a directory defined by the user, see image 

right, which can be done in one of three ways: 

a) On the Lists tab of Extended Entity Info, at the bottom, is a new section 

called To Select A Directory For Back-up Files:. Click on the folder icon 

to the left and select a directory using the Select Folder dialog box. This 

should be done when CabWriter is installed. This only has to be 

specified one time. 

b) If the default directory has not yet been specified at the time the user first clicks the Backup List 

button, the Select Folder dialog box will automatically open and the user can specify the default 

directory and then backup the selected file. 

c) If the default directory has not yet been specified at the time the user first clicks the Restore List 

button, the Select Folder dialog box will automatically open and the user can specify the default 

directory and then restore the selected file; provided it exists in the selected directory. If the file 

does not exist a message will inform the user. 

6. Changed the dialog box used when the Save CabWriter Defaults tool is selected. The dialog box is 

now the File Explorer on Windows systems and the Finder on Mac OSX systems. The user can now 

see the names of previously saved defaults, select one and overwrite it, or supply a different name. 

Whatever extension the user supplies, CabWriter will replace it with .cwd (CabWriter Defaults). 

 

 



  



7. Changed the Attributes tab of the Extended Entity Info dialog box. 

The Component Type attribute (in the Cabinet/Resize Mode 

section) is now visible whenever Milled Parts is selected; its 

visibility is no longer a function of either Cabinet/Resize Mode or 

Enable Auto-Swap?. In addition a new selection has been added to 

the Component Type drop down called Custom.  

 

The Component Type attribute will automatically be set to Custom 

whenever the Make CabWriter Component tool is used and the 

Component Type (CP) Custom Part is selected in the drop down 

box. 

8. Added numerous .cwd default files to the factory installation of 

CabWriter. At the moment, all of them are Imperial defaults, but 

with the next release I will add an equivalent set of Metric defaults. These defaults are intended as a 

jumping off place for the user to further modify and make their own by saving defaults in their 

chosen folder and with their chosen naming convention. 

Fixes 

1. Fixed an issue with the Associate Material to Hatch dialog box. The Scale drop down box had both a 

1 and 1x scale option. The 1 choice returned a scale value of 0.0 and created a SketchUp error. The 

choice of 1 was removed. 

2. Fixed an issue when drawing frameless cabinet with Face Frame /Hybrid selected for Cabinet Style 

on the Project tab of CabWriter Settings. If either a left or right sheet or panel stile was not drawn 

the doors and draws would not grow in width to extend to the end sheet or panel. 

3. Similar to fix 2 above, top and bottom rails did not extend to the end sheet or panels of a cabinet. 

4. Fixed a problem when a sheet stile on the right side of a cabinet was not drawn and the cabinet was 

at an angle to the red axis; the sheet panel was not positioned correctly. Usually moved to the inside 

and front of the cabinet. 

5. Fixed a problem with divided upper and base cabinets. If captured sides and inset construction 

method were both chosen, the pockets for any fixed shelf were in the wrong place. 

6. Fixed a problem with divided upper and base cabinets. I inset construction method was chosen, the 

Shelf Offset parameter would operate correctly for shelves, but on stretchers it would offset the 

pocket but not the stretcher. The code was changed to have Shelf Offset apply correctly to both. So 

the parameter name was changed to just Offset. 

7. When Slab Doors and Drawers was chosen, or when a Drawer size was too small for a frame and 

panel, the wrong material type and name was stored by CutList Bridge, The correct material type 

and name is that which is specified by Slab Door/Drawer Front defaults on the Project tab. 

  



Changes in CabWriter Version 2.0.0 Beta 3-20-2018 

New Functionality 

1. Converted the Production Documentation dialog box to the new UI::HtmlDialog introduced in 

SketchUp 2017. Beginning with SketchUp 2017 SketchUp ships with a platform-independent web 

browser called Chromium. The advantage is that the browser is the same in PC and Mac platforms 

and should look the same. As a developer I no longer have to tailor the dialogs for the specific 

platform. The Production Documentation dialog box will now look a little different from the rest of 

the dialog boxes. Significant changes are the borders of the field boxes and no minimize or maximize 

bottoms in the dialog bar. I have 35 more dialog boxes to convert, which may occur over a number 

of releases. 

2. Rearranged and modified the CNC Boring tab of CabWriter Settings. There is a new section called 

DXF Layers which corresponds to the layer names used in producing the DXF files. Depending on the 

specific CNC machine the DXF output is intended for, these names might be interpreted as 

instructions to the machine. So we have provided the ability for the user to change the default 

names to names that carry out the desired milling. Below is the default names: 

And here is a typical substitution: 

 

 

 



3. Added one parameter to each of the Base Cabinets and Upper Cabinets tab in the CabWriter 

Settings. Remember that anytime I add parameters you will need to use the Re-Load Factory 

Settings tool and save your model to pick up the new parameters. This new parameter, called Side 

Position, has two options: Outside and Captured. 

 

When selected, Outside you produce the cabinet construction we are used to: the top/stretchers 

and bottom are enclosed by the sides. Captured is just the opposite: sides are enclosed by the 

top/stretchers and bottom. The advantage of Captured is primarily that cabinet length will not vary 

with slight changes in plywood thickness because the width of the boxes are determined by the 

top/stretcher and bottom length. Note: these parameters have no effect on the Diagonal Corner 

boxes, Lazy Susan boxes or Refrigerator boxes. Here are two examples of the differences. Notice 

also the difference in where the construction holes are drilled. 

 

 
4. Removed the restriction that a Divided Base box had to have a solid top. It can now be constructed 

with stretchers for a top. 

5. Added Education licenses for Pro and CNC. 



Fixes 

1. Fixed a problem where an illegal file name could be formed from the Project Name of the Project 

tab in CabWriter Settings and create a SketchUp error which would only appear in the Ruby Console. 

Now the user gets a message to examine the Project Name. 

2. Fixed a problem that occurred only on Mac systems, where the Project Name, created at the time 

the user uses Create Project, included not only the .skp file name, but also the entire path. 

3. Fixed a problem with the with the Production Documentation dialog box. If DXF by Material Name & 

Thickness was unchecked and the DXF Scene was blank a message would appear instructing the user 

to select a valid DXF Scene, even though one was not necessary. 

4. Fixed a problem introduced with the addition of the CabWriter Production Documentation 

command. When the user chose CutList Plus fx with DXF, the DXF files were generated but the file 

location of the DXF files were not included in the .cwx file. Hence, when exporting DXF files from 

CutList Plus fx no hole geometry appeared. 

Changes in CabWriter Version 2.0.0 Beta 2-25-2018 
 

Important Note: 

In this release there are a number of changes to Sectioning, Hatching and LayOut tools. You will read 

about them below. But here are some guidelines and rules of use you should be aware of in order to use 

these tools appropriately: 

1. Your model must completely reside in quadrant 1; i.e. positive R, G and B axes. Sections must be 

parallel to the Red/Green plane for plan views, and parallel to either the Blue/Green plane or the 

Blue/Red plane for elevation views.  

2. Do things in the order suggested by the order of the command list in File > CabWriter to LayOut. 

3. Assign Hatches first, and be certain that you have the ones you want so you don’t have to change 

the assignment later. If you make a change later when you have a number of scenes with sections, 

you are likely to have to delete all section cuts (those on Z layers) and recreate them. 

4. Only when you are sure the model is final, i.e. there are likely to be no future changes, should you 

begin creating scenes. At that point you should use Create Sections From Section Planes to create all 

plan and section scenes. Choose the name of all scenes carefully, because those will be the names of 

the Pages and drawing titles in LayOut. You DO NOT want to change those names in LayOut later, 

especially if you have done dimensioning. So when naming a scene be sure it is the name you want 

to see in LayOut. 

5. At this point you want to freeze your design and use the CabWriter Production Documentation 

command to produce the cut lists, CSV files and DXF files you will need. 

6. Use the LayOut Document Setup command to specify the template you will use, its margins, line 

weight and default scale. 

7. Use the Send Scenes to LayOut command to transfer all of your scenes to LayOut; there will be one 

page in layout for each scene in SketchUp. You can use this command multiple times if you add 

scenes after its first use. Each time you use this command it will add any new scenes to pages in 

LayOut, but will not change previously transferred scenes. That must be done in LayOut with the 



update feature. Also, if you delete a scene in SketchUp you need to manually delete its 

corresponding page in LayOut. Always close the LayOut file before using this command again. 

8. Use the Hatch Sections in LayOut to add patterns to the sections in LayOut. CabWriter will create a 

Hatch layer in LayOut where all the section hatching will reside. You can use this command multiple 

times, but before each subsequent use delete the Hatch layer and its contents in LayOut and then 

save and close the file. 

Doing things in this order and following these guide lines will make creating LayOut model files easy. Of 

course you can always make changes at any step along the way, but those changes will result in rework 

and can be quite time consuming. So be sure you model is really ready before proceeding to the next 

step. 

New Functionality 

1. Changed how the Assign Hatches tool works. Before you could use the Assign Hatches tool you 

needed to bring the hatch materials you wished to use into your model. This is no longer necessary. 

CabWriter provides the needed materials and they are loaded into the In Model Materials dialog 

box when the Assign Hatches tool is selected. 

 

The updated Associate Material to Hatch dialog box, which appears when the user chooses the 

Assign Hatches tool, is shown below. 

 

Notice that it is wider; now 600 pixels wide. This was done to allow for long material and hatch 

names. Also notice the OK button has been removed. The Cancel button starts out as Cancel. 

 

When the dialog box first opens CabWriter collects all the Material Types used in the model, and for 

each Material Type, it collects all the Material Names used in the model. Initially the First Material 

Type will be set in the Material Type field, and the first associated Material Name is loaded into the 

Material Name field. CabWriter also collects all the CabWriter Materials in the model and loads 



them into the Hatch Name dropdown, with None being the first valid selection. 

 

The Rotation and Scale drop down fields permit the user to select parameters used by LayOut to 

manage patterns; these parameters will be placed in the Pattern Fill dialog box in LayOut in the 

Rotation and Scale fields. In LayOut, patterns can be rotated and they can be scaled. This is useful in 

matching pattern sizes and orientation to drawing shapes and sizes. These parameters have no 

effect in SketchUp. 

 

All five fields are drop down boxes. The procedure for assigning hatches (SketchUp Materials) to 

each CabWriter Material is as follows: 

a. For the initial Material Type and initial Material Name choose a hatch name from the Hatch 

Name dropdown. You selection will automatically be saved. 

b. Select the next Material Name from the Material Name dropdown. Choose a hatch name 

from the Hatch Name dropdown. Each time you make a selection from the Material Name 

drop down CabWriter will check to see if that combination of Material Type/Material Name 

has been assigned a Hatch Name, and if it has that name will be loaded into the Hatch Name 

field. Otherwise the Hatch Name Field will display None. None is a valid selection for a hatch 

pattern. 

c. Repeat step b until you have assigned a Hatch Name for each Material Name in the Material 

Name dropdown. 

d. Select the next Material Type in the Material Type dropdown. Call this the initial Material 

Type and repeat steps a through c until each Material Type and each of its Material Names 

have been assigned a Hatch Name. At this point the Cancel button will be renamed to Done. 

See the image below. 

 

Each time you make a selection from the Material Type drop down CabWriter will check to 

see if that combination of Material Type/Material Name has been assigned a Hatch Name, 

and if it has that name will be loaded into the Hatch Name field. Otherwise the Hatch Name 

Field will Display None. None is a valid selection for a hatch pattern. 



e. You can click Done at this point, or continue to make changes to any Material Type/Material 

Name combination. When satisfied Click Done. 

 

 

If you click Cancel before Done you will be asked if you are sure you want to Cancel. If you 

answer Yes you will exit the Assign Hatches tool and all of your assignments will be lost. 

 

Once you have assigned all of your materials a hatch pattern and click Done, all of the 

assignments will be saved in the model file. Therefore you can close the file and upon re-

opening the file you will have the same assignments available. 

 

Note, that when you reopen the Associate Material to Hatch dialog box in a model that has 

already assigned hatches to materials, those Hatch Names will appear in the Hatch Name 

field. Further, unless you have added material types or material names in the interim, the 

Cancel button will be named Done, indicating that all the materials have been assigned a 

hatch pattern. You don’t have to click the Done button at this point; you can proceed to 

make changes or just review your assignments. 

 

If you have added either material types or material names since last opening and closing the 

dialog box, the assignments that you previously made will show up in the Hatch Name field. 

The new assigned types or names will have None in the Hatch Name field and the Cancel 

button will still be named Cancel indicating that there are more assignments to be made. 

2. Made a number of changes to the Draw > CabWriter > Create Section From Section Plane to make it 

easy to recreate or redefine a current section. If you are creating a section for the first time you 

proceed as usual, by placing a section plane where you want it using the SketchUp Section Plane 

tool, and then select Draw > CabWriter > Create Section From Section Plane. Note: Since you just 

placed a new section plane, it is the active section cut, and you do not have to select it as you did in 

the past; just proceed directly to the Draw > CabWriter > Create Section From Section Plane 



command. Provide a section view name and color and click OK and the section mask and scene will 

be created. 

 

Now here is the big change. If you make changes to your model that requires a section change, you 

have several options. You can begin by placing a new section plane with the Section Plane tool; or 

you can use the Display Section Planes tool to display the current section planes and you can choose 

one by selecting it with the Select tool. Then choose the Draw > CabWriter > Create Section From 

Section Plane command. Type in the name of the section you wish to change exactly as it currently 

appears in the scene tab (or Scenes dialog box). You will get the following user message. 

 

You have three options. Click Yes will delete the current section mask, create a new one with the 

model changes and place it on the same Z layer the old one was on. Click No and the old section 

mask will not be deleted, a new one reflecting model changes will be placed on the same Z layer and 

will be the active cut. Click cancel to exit without any changes. 

Another option now available is to create a new section, with a new name, but using an existing  

section plane. Simply use the Display Section Planes tool to display currently available section and 

choose one with the Select tool. In the Section View dialog box, which appears following the 

selection of the Draw > CabWriter > Create Section From Section Plane command, provide a new 

(unused) name. 

 

The last change is that when you use the Draw > CabWriter > Create Section From Section Plane 

command the Shaded With Textures rendering option is selected. This is to ensure that the scene 

will display any hatching that the user assigns. 

3. Made some more changes to the Draw > CabWriter > Create Section From Section Plane command. 

The user now has a choice of three modes for creating a section. See the image below. 

 

All – All is the normal mode. The section includes all CabWriter components, including walls, in the 

section cut. All layers that contain a CabWriter component or wall are visible in the created scene. 

 

By Selection – Any selected CabWriter components or wall will be in the section cut. Components or 

walls not selected will be hidden. Selection can be accomplished with the Select tool or any of the 

CabWriter section tools such as the context menu CabWriter > Select Cabinet. Only the layers that 



selected CabWriter components or walls reside on are visible. You can choose a section plane from 

one that currently exists in the model or use the Section Plane tool to create a new one. Whichever 

method is used, you must actually select that section plane with the Select tool. So the order is 

important. To use a currently available section plane follow this procedure: 

 

a. Make your selection of 

components first. 

b. Choose the Display Section Planes 

tool to make all section planes 

visible. 

c. Press and hold the Ctrl key and 

with the Select tool select a 

section plane. This will add that 

plane to the selection. 

d. Choose the Draw > CabWriter > 

Create Section From Section Plane 

command. 

e. Choose the By Selection radio 

button. 

 

To use a new section plane follow this procedure: 

 

a. Us the Section Plane tool to place and located your desired section cut. 

b. Make your component selections. 

c. Press and hold the Ctrl key and with the Select tool select the new section plane. This will 

add that plane to the selection. 

d. Choose the Draw > CabWriter > Create Section From Section Plane command. 

e. Choose the By Selection radio button. 

By Layer – You can choose one or more layers from which to create a section view. All of the CabWriter 

components and walls on those layers will be included in the section cut and only those layers will be 

visible in the created view. Follow this procedure. 

a. Make only the desired layers visible. 

b. Create a new section plane with the Section Plane tool or select a currently available 

plane. 

c. Choose the Draw > CabWriter > Create Section From Section Plane command. 

d. Choose the By Layer radio button. 

 

After the view is created the user may have to choose a standard camera view from the view icons 

or the Camera > Standard Views menu. I hope to rectify this in a future release. 

 



The selections you make in the Section Color dropdown and the radio buttons will be saved and will 

be the default selections the next time the Selection View dialog box is opened. 

4. When a CabWriter project is created, each time the user selects the Assign Hatches tool the pattern 

files in the Plugins\cabwriter\hatch files\ folder are loaded into the In Model Materials library so 

they are available for hatch association with the Assign Hatches tool. There are currently thirteen 

pattern files available, listed below. 

a. Adobe Rammed Earth 

b. Aluminum.skm 

c. Basketweave.skm 

d. Black Dots 1 

e. Brick Common Face 

f. Concrete Masonry Unit 

g. Herringbone 2x1.skm 

h. Honeycomb.skm 

i. Plywood.skm 

j. Rectangles Running 3x1 

k. Steel 

l. Terrazzo.skm 

m. Windmill.skm 

 

5. Added a new File menu command category called CabWriter to LayOut which has two sub-menus: 

a. Assign Hatches 

b. Create Section From Section Plane 

c. LayOut Document Setup 

d. Send Scenes to LayOut 

e. Hatch Section in LayOut 

 

The ordering of theses commands are the order in which they operations should be 

performed. Assign Hatches tool is the same tool as the Assign Hatches tool icon; it is 

included here to provide a visual sequence to follow. Create Section From Section Plane is 

also placed here to show the order and is the same as Draw > CabWriter > Create Section 

From Section Plane. 

 

This new File menu and its sub-menus will only appear if the SketchUp version is 2018 or 

higher. The purpose of these commands is to permit the user to define a LayOut file, using a 

selected template, and send each scene in the SketchUp model to a LayOut page. When 

completed the LayOut file will open. The LayOut file location will be the same folder that the 

SketchUp model resides in, and the LayOut file name will be the same as the SketchUp 

model but with a .layout extension. 

 

Before using these commands the user should open LayOut and create one or more custom 

templates and use the LayOut File > Save as Template command to place them in the users 



template folder; LayOut will automatically place them in the correct folder. Do not change 

their location because CabWriter will expect to find them there. There should be one 

template for each paper size the user intends to use, and for each of portrait or landscape 

orientation desired. LayOut has a lot of base templates the user can begin with, but they 

must be saved in the user’s folder using File > Save as Template. Print out each template for 

measurements you will make shortly. 

 

Once you have saved one or more templates use the File > CabWriter to LayOut > LayOut 

Document Setup command to open the LayOut Document SetUp dialog box shown below. 

 

 

 

Choose a paper size from the Paper Size drop down. Select either Landscape or Portrait 

from the Orientation crop down. Select a template from the Template drop down; in the 

image above I chose NESAW (New England School of Architectural Woodworking, 

nesaw.com ). See the NESAW template on the next page. Using the printout for this 

template measure the margins on each side required to place a scene within the useable 

space. For this NESAW template, which is 24” x 36”, I determined that a 1” left and top 

margin was best. The right required a 7” margin because of the title box and the bottom 

2.5”. I entered these into the Template Margins fields. 

http://www.nesaw.com/


  



After filling in the margins fields the user must select a line weight from the Line Weight drop down box. 

This parameter is placed in two places in the LayOut model file: for each Page in LayOut, in the SketchUp 

Model dialog box Styles tab, it will be written into the Line Weight field; second in the Shape Style dialog 

box it will be placed in the Stroke line width field (this field is not labeled). The default Line Weight in 

CabWriter is 0.40pt. This seems to be a good line weight both visually and for printing. 

Next the user needs to select a Model Scale. CabWriter’s default for this is 1 : 10, meaning 10 units of 

length in the SketchUp model will be drawn in 1 unit of length in the LayOut template paper space. The 

units are unit-less, but a Model Scale of 1 : 10 can be interpreted as 1”(1mm) in LayOut equals 10” 

(10mm) in the SketchUp model. This default Model Scale works pretty well for kitchen models 

transferred to Arch D paper in LayOut. It will be used in each Scene/Page pair for scenes that use 

Camera > Parallel Projection rendering in the SketchUp model. 

When the Assign Hatches, Create Section From Section Plane and LayOut Document Setup 

commands/tools have been used in that order, and all of the scenes the user desires have been created, 

the user is ready to use the Send Scenes to LayOut command. Remember that the Create Section From 

Section Plane tool creates one scene and one section layer and therefore must be used multiple times to 

create all the plan and sections views required. The Send Scenes to LayOut command will create a 

LayOut document with the same name as the SketchUp model and place it in the same folder. Within 

the LayOut model CabWriter will create a page for each scene with the same name as the SketchUp 

scene. The user should not change these names in LayOut; rather make sure the scene names in 

SketchUp are the names you will want in LayOut. CabWriter will place all of the scenes content on a 

LayOut layer called Models for each page. If the file doesn’t have a Models layer CabWriter will create 

one. When it is done it will save and open the file. 

Once the LayOut model file has been created, the user can, and absolutely should at that time, adjust 

the scale of each Page in LayOut to a scale that is optimal for that page. Be sure to do this before using 

the Hatch Sections in LayOut command. An example of one such page can be seen on the next page. The 

model didn’t take quite the entire usable space because of the scale I used for that page; 1 : 2.25. 

However, since this page is not yet dimensioned this is probably a good thing. 

If you add scenes to the SketchUp model after creating a LayOut file you can use the same process to 

update the LayOut file. CabWriter will leave the current scenes untouched and just add the new scenes. 

The user is now ready to use the Hatch Sections in LayOut command. This command will replicate the 

sections in SketchUp on a Hatch layer in LayOut, applying the hatch material with the Rotation and Scale 

parameters applied. Hence the hatches may look different than in the same scene in SketchUp. Prior to 

using this command it is suggested that the LayOut document be closed. It will reopen one the LayOut 

hatching is complete. 



  



6. Added a feature to the Section View 

dialog box, which appears when the 

user selects Draw > CabWriter > 

Create Section From Section Plane. 

When this dialog box opens the Use 

Selected Scene Name? check box is 

unchecked. The Section Name field 

is populated with the suggested 

name of Section – A. If the user 

checks the Use Selected Scene 

Name? check box the Section Name 

field will be populated with the 

name of the current active scene. If 

the check box is unchecked the 

Section Name field will revert to the suggested name of Section – A. 

7. Added one more button to the 

Associate Material to Hatch dialog 

box. The name of the button is 

Save Partial Assignments and 

Close. There are times when the 

user does not want or need to 

assign a hatch material to all 

CabWriter components; e.g. 

Walls. This button permits the 

user to assign one or mare 

materials and save them without 

waiting for the Cancel button to turn to Done. Any material that is not assigned will automatically be 

assign the defaults of None for Hatch Name, 0 for Rotation and 1 for Scale. All other buttons and 

drop downs work as previously described. 

8. Changed what sheet good components are included in DXF reports. In the past only box parts were 

included; e.g. those with prefixes like C2UB6 Back. This meant that parts such as frame and panel 

door panels were not included in a DXF report. Now, and sheet good is included. 



9. Made yet another change to the 

Production Documentation dialog box. 

This change was made to eliminate the 

possibility of double accounting when 

producing CabWriter Production 

Documentation. A number of users like to 

create scenes such as exploded views. This 

generally meant copying cabinets from 

one scene to an exploded view scene, and 

then pulling the parts away from the 

center to show how they are assembled. 

This meant that there were duplicates of 

some parts in the model and hence the 

possibility of double accounting them in 

the cut list or DXF files. 

 

The solution we came up with is both 

simple and useful. To use the CabWriter 

Production Documentation command you 

must first create at least one scene in the 

model; preferably three or more. One 

scene should be dedicated to generating a 

Doors & Drawers report if you plan to 

purchase those from a third party. In the 

model on the next page I have created a 

Purchased Parts scene which includes 

layers Base and Upper Doors, Drawer 

Boxes and Drawer Fronts. No other layers, 

except of course Layer0, are included. 

 

Similarly, I created a Cut List scene 

dedicated to producing a cut list of every part that will be milled and produced in the shop. This 

included layers Base Back Panels, Base and Upper Boxes, Base and Upper End Panels, Base and 

Upper Face Frames, Base Ladder and Crown Molding. Crown molding is not a CabWriter component 

and will not show up on the cut list unless you use Make CabWriter Component on them and assign 

them a custom part prefix; e.g. C10UCP Crown Molding #6. Notice that the doors, drawer fronts and 

drawer boxes do not show up in this scene because they will be purchased from a third party. 

 

Lastly I created a DXF scene with only layers Base and Upper Boxes. This is all I want cut on the CNC 

machine. Now, with these scenes created, I assign them in the Production Documentation dialog 

box using the Door & Drawer Scene, Cut List Scene and DXF Scene drop down boxes. So when 

producing the Doors & Drawers report CabWriter will only include those parts included in the 



Purchased Parts scene; the Cut List will include only the parts in the Cut List scene and the DXF 

report will include only the parts in the Cut List scene. 

 



   



10. Modified the CabWriter toolbar. I re-arranged it and organized it with separators. Also added a new 

tool icon for the “CabWriter Production Reports” command. 

11. Added a message at the beginning of the CabWriter Production Documentation command that let 

the user know that this command can take several minutes, depending on the number of reports 

chosen and the size of the model. It also warns the user to close the Outliner dialog box, which can 

double or triple the compute time of this command. 

Fixes 

1. Fixed a problem when selecting the Make CabWriter Component tool with no entities selected; this 

would result in a Ruby Console error instead of a user message box. 

2. Fixed a problem when using the Draw > CabWriter > Create Section From Section Plane tool on 

components without Extended Entity Info attributes. This would raise a SketchUp error in the Ruby 

Console, but not a user message box indicating the error. Now the user gets a message similar to 

that below. 

 

 
 

The user needs to fix this component and any others that don’t have Extended Entity Info attributes. 

This can be done with either the Extended Entity Info dialog box or the Make CabWriter Component 

tool. 

3. Fixed a problem with the File > CabWriter Production Documentation were an error occurred in you 

did not include either Drawer Fronts, Drawer Boxes or Doors in your selection of reports. 

4. Fixed a problem with the Make CabWriter Component tool. When used on renaming or creating 

door or drawer parts the CutList Bridge attributes were not assigned. 

5. Fixed a bug in the door and drawer reports where slab door quantity was not provided. 

6. Eliminated the tilde (~) symbol from dimensions output in the door and drawer reports. 

7. Permitted the choice of no scene selection in the Production Documentation dialog box if the 

corresponding report was not selected. 

8. Provided a message in the Production Documentation dialog box that requires a type of cut list to be 

selected when requesting a DXF report. 

9. Fixed a problem where the CabWriter Production Documentation tool could try to generate a DXF 

report before a cut list report which would generate errors.  

10. Fixed a problem where there could be gaps between a sheet end, panel end or open end and the 

side of a cabinet when drawing frameless cabinets. 



11. Fixed a problem where Add a Door failed when drawing the door rectangle on the face of the box 

sides. 

Changes in CabWriter Version 2.0.0 Beta 1-1-2018 

New Functionality 

1. Added more profiles for cope & stick joinery and provided code that now allows these profiles to be 

used on doors, drawer fronts, end panels and back panels greater than ¾” (19mm). 

a. Outside Edge Profiles 

i. Basic 

ii. Bevel 45 

b. Inside Edge Profiles 

i. Basic 

ii. Bevel 45 

iii. Chamfer 

iv. Inset Radius 

v. Ogee 

vi. Standard 

c. Panel Edge Profiles 

i. Basic 

ii. Cove Raised 

iii. Curve Raised 

iv. Shaker Raised 

v. Standard Raised 

2. Changed the context menu CabWriter > Select Sub-Assembly to remove the work Select in front of 

all the sub-menus. 

 

 



3. De-Stileized CabWriter. CabWriter appeared to many to be a face frame only drawing tool, largely 

because that was its genesis and because the Story Stick is focused primarily on placing stiles. In this 

release we are changing the face frame centric nature of CabWriter. This involves many changes, 

but they can be divided into two major categories: 

a. Distinct Cabinet Design Styles 

There are now three distinct cabinet design styles listed in the Cabinet Style drop down in 

the General section of the Project tab: Face Frame / Hybrid; Frameless Hybrid; and Overlay. 

This is shown below. 

 

 
 

Face Frame / Hybrid is the default set by the factory settings and the Re-Load Factory 

Settings tool. However, before, when Face Frame was chosen, all of the Draw? check boxes 

on the Face Frame tab were locked, except Bottom Rail. Now, when you choose Face Frame, 

all checkboxes are checked but they are all free to be changed, hence the addition of Hybrid 

to the name. 

 

Similarly the Draw? Check boxes are free to be changed in Frameless / Hybrid style, though 

they start out all unchecked, to represent pure frameless. Hence again the Hybrid addition. 

 

The major difference between Face Frame and Frameless is how the cabinet ends are 

treated. End Panels, End Sheets, or End Openings will extend to the front surface of the 

doors and drawers in the Frameless style. 

 

The Overlay style treats End Panels, End Sheets, and End Openings the same as Face Frame; 

i.e. they terminate at a stile with either a miter or butt joint. The doors and drawer fronts in 

the Overlay style sit on, and overlay the face frame by an amounts specified by the 

Door/Drawer Overlay Distance default in the General section of the Project tab. 

 

The last part of the distinct cabinet design styles change is that the Face Frame Door/Drawer 

default in the General section of the Project tab has been removed. 

b. The Story Stick Defines Cabinet Ends, End Treatment and Connections 

Users should now think of the Story Stick as a tool to define the ends of cabinets, 



connections between boxes and how cabinet ends are 

finished. Here are the choices for cabinet ends: 

i. Wall – This is used when cabinets are ending at or 

near a wall. If the Wall Stile Draw? Checkbox is set a 

Wall stile will be drawn with scribe allowance added. 

ii. Panel – This is used when a cabinet will end with a 

frame and panel. If the End Panel Stile Draw? 

Checkbox is set an End Panel Stile is drawn and the 

end panel terminates at the face frame with either a 

miter or butt joint. If the checkbox is not set, the stile 

is not drawn and the end panel will terminate at the 

door/ drawer front. The user should choose a butt 

joint t square the end panel off. 

iii. Sheet – This is used when a cabinet will end with a 

sheet good panel. If the Sheet Stile Draw? Checkbox is 

set a Sheet Stile is drawn and the end panel 

terminates at the face frame with either a miter or 

butt joint. If the checkbox is not set, the stile is not 

drawn and the end panel will terminate at the door/ 

drawer front. The user should choose a butt joint t 

square the end panel off. 

iv. Opening – This is used when a cabinet will end with an opening for a dishwasher, 

sink or other appliance. If the Open Stile Draw? Checkbox is set an Opening Stile and 

filler is drawn and the filler panel terminates at the face frame with a butt joint. If 

the checkbox is not set, the stile is not drawn and the filler will terminate at the 

door/ drawer front. 

v. Connector – This is used when a cabinet will end next to another cabinet. If the 

Connector Stile Draw? Checkbox is set a Connector Stile is drawn. If the checkbox is 

not set, the stile is not drawn. In either case connector holes will be drawn in the 

side if enabled. 

vi. Finish – This is used when a cabinet will end next to another cabinet’s finished panel 

or other finished object; for example a refrigerator cabinet side. If the Finish Stile 

Draw? Checkbox is set a Finish Stile is drawn. If the checkbox is not set, the stile is 

not drawn. In either case connector holes will not be drawn in the side and no scribe 

allowance is provided. Note: Finish use to be called Filler. The names Filler and 

Scribe will now be reserved for a future change that will allow custom parts that the 

designer can add using native SketchUp tools and the Make CabWriter Component 

tool. 

vii. Butt – This is used when a cabinet will end next to a Blind Corner cabinet. If the 

Blind/Butt Corner Stile Draw? Checkbox is set a Butt Corner Stile is drawn. If the 

checkbox is not set, the stile is not drawn. 



viii. Blind – This is used with a Blind Corner cabinet on the end that extends toward the 

wall. If the Blind/Butt Corner Stile Draw? Checkbox is set a Blind Corner Stile is 

drawn. If the checkbox is not set, the stile is not drawn.  



4. Changed the File > CutList Bridge (and CutList Bridge DXF) sub-menu; I deleted all but two sub-menu 

commands: Export to CutList Plus fx and Export to Microsoft Excel or OpenOffice. NOTE: These two 

remaining commands should only be used on NON-CabWriter projects and should NOT be used on 

CabWriter projects. See menu below. 

5. Added a CabWriter command to the File menu. File > CabWriter Production Documentation should 

be used whenever the user wants cut lists, DXF files or door & drawer schedule reports. All 

documentation will be placed in a folder, with a name equal the Project Name in the Project tab, 

and the folder will be placed in the same folder as the applicable .skp file. 

 

 



When menu File > CabWriter Documentation is chosen the user will be presented with the following 

dialog box. 

 

 

 

The Cut List Files Delimiter can be selected to Comma, Tab or Semicolon. Comma is most common in 

countries that use a period for the decimal point. Semicolon is very common in countries that use a 

comma for a decimal point or where there is a lot of commas in use in their reports. Be sure the 

application that you are using to open the spreadsheet .csv and .cwx files are set to the same 

delimiter. 

 

In the Select Desired Reports field the user can select the reports required. The first three selections, 



Drawer Fronts, Drawer Boxes and Doors, will be included in a door_and_drawer_schedule.csv file 

which can be opened in any spread sheet application. This report will look something like the image 

at the top of the next page. All of the dimensions in this report are finished dimensions EXCEPT 

those in the red squares. Those dimensions are the finished height and width but oversized on each 

edge by the amount entered in the “Oversize each side and end by:” field on the Production 

Documentation dialog box. If you leave this field blank or zero, the dimensions in the red squares 

will be finished dimensions. The third line of the report, shown in a red ellipse, shows the value of 

the oversize for reference. 

 

If a door or drawer is a slab it will be listed in either the Slab Doors or Slab Drawer Fronts section. If a 

door or drawer is a frame and panel it will be listed in the Frame & Panel Doors or Frame & Panel 

Drawers sections. In all of these sections the slab prefix or the frame and panel prefix is listed. This is 

the same prefix that shows up in the Sub-Assembly section of the cut list if the Extended Entity Info 

Setup tab is set to Sub-Assembly Attribute in the Sub-Assembly section. Also included in these 

sections is the quantity of slabs or frame and panels required for each prefix (sub-assembly), the 

thickness and in the case of frame and panels the width of the stiles, top rail and bottom rail. 

 

This door_and_drawer_schedule.csv is intended to help shops that purchase drawer boxes, drawer 

fronts and doors from a third party. In the case of Drawer Boxes it will tell the user the number of 

each type slides in pairs i.e. each box requires one pair. It will include the manufactures name and 

part number. This information comes directly from the Drawer Box Depth section of the Drawers 

tab. 

 

The Drawer Boxes section of the door_and_drawer_schedule.csv will list the unique box sizes 

required with a name Drawer Box #, the Width, Height, Depth and the Quantity of each. This report 

will also place in the notes field of each drawer box on the cut list the Drawer Box # for cross 

reference. In CutList Plus fx output, the drawer boxes are in the Other Items tab, and that note 

appears as a little red triangle. As your cursor hovers over the triangle you will see the Drawer Box # 

as shown at the top of the page after the next page. 

  



 

You can choose a Spreadsheet Compatible Cut List and/or DXF by Material Name & Thickness by 

checking the appropriate checkbox. CutList Plus fx has three radio buttons and you can select only 

one at a time. CutList Plus fx provides only the usual cut list. CutList Plus fx provides a folder of 

individual CabWriter SketchUp component .dxf files which will be used by CutList Plus fx to output 

optimized .dxf sheet files. If you do not want a CutList Plus fx file simply choose No CutList Plus fx 

Report. 

 

When you click the OK button CabWriter will begin report generation. The dialog box will remain 

open until you get a message that the reports are complete and it will inform the user where to find 

them. When you click OK both dialog boxes will close.   



 

 

6. Changed what gets generated for DXF files. In older revisions any component with a Material Type: 

Sheet Good would be included in a DXF file. This meant that panels in doors, drawers, end panels 

and back panels would be included in the DXF file. In this revision we have limited the DXF 

generation to only Box components e.g. C10UB1 Bottom. This means that only carcass parts are 

included in DXF generation. This was done because panel plywood, which is typically ¼” (6mm) 

thick, is generally not cut on CNC machines. We may revisit this decision later with more user input. 

7.  

Fixes 

1. It appears that when saving a SketchUp 2018 file as a SketchUp 2017 file, there is a problem with 

the DefinitionList.load method (and perhaps other issues as well). Implemented a work around for 

this situation. 

2. Fixed a bug where the Save CabWriter Defaults tool was not erasing unregistered defaults before 

saving defaults to a file. 



3. Fixed a problem where old models with Extended Entity Information attributes written prior to the 

revision that included Resize Thickness By would cause errors when opened and examined in 

current CutList Bridge versions. 

4. Fixed a problem where when Solid top was chosen for base cabinets, Stretcher holes were drilled, 

not solid top holes. 

5. Fixed a problem where when using an inset bottom value, the bottom drawer box did not move up 

accordingly. The hardware holes did, but not the drawer box. 

6. Fixed a problem where when manually adding a drawer to a divided cabinet with a raised bottom 

the hardware holes and the drawer box did not move up accordingly. 

7. The context menu CabWriter > Set CabWriter Protection did not set the attribute to the correct 

value even though it showed as protected in the Extended Entity Info dialog box. Hence, the 

component wasn’t protected when a Re-Draw tool was used to re-draw a cabinet. 

8. Fixed a problem with drawing corner cabinets with non-end panel or sheets when there was only 

the corner box in the cabinet. Multiple box configurations had no problem. 

9. Fixed a problem where corner cabinet End Sheet panels extended to the face frame like they would 

for frameless. 

10. Fixed a problem with using the Insert a Door tool in an upper cabinet Divided Upper. 

  



Changes in CabWriter Version 2.0.0 Beta 12-8-2017 

New Functionality 

1. The Insert a Door, Insert a Drawer and Create a Back Panel now give the user the option of using the 

cabinet’s stored defaults or the current CabWriter Settings defaults. In the unlikely example below, 

the cabinet was constructed a frameless cabinet with End Sheet end panels. The CabWriter Settings 

were modified to use cope & stick back panels and then the back panel was added using those 

settings, not the cabinet’s stored settings. 

 

 

2. When using the Create a Back Panel tool the Back Panel dialog box input field is now case 

insensitive. See legitimate input in image below. 

 

 

 



3. Added a new default on the Carcass tab at the bottom of the Toe Kick section called ‘Draw Toe Kick 

Frame?’. The options are Yes or No. Yes means that the entire ladder base is drawn. No means that 

the stretchers, ribs, and ties are not drawn leaving only the applied trim faces. See the images 

below. 

 

4. Combo Drawers drawn without a mid-stile now have one Drawer Support between them as 

opposed to a Left Drawer Support and Right Drawer Support. This is true for all base cabinet types 

that permit Combo Drawers. If the mid-stile is drawn then there is both a Left Drawer Support and 

Right Drawer Support. Thickness of the single draw support is the same as the box sides. See the 

Base Cabinets tab on the next page. 

  

 

 



  

Fixes 

1. Fixed a problem where when checking thickness, tongue length and tongue width in cope & stick 

creation, the comparison of dimensions could fail due to floating point inaccuracies. 

2. Fixed a problem in SketchUp 2018 that did not permit the drawing of combo drawer fronts. 

3. Fixed numerous problems created by SketchUp 2018. The explode method returns an array of 

entities. Those entities in 2018 can now include class AttributeDictionaries. 

4. Fixed a problem when drawing a multi-box cabinet with a Lazy Susan or Diagonal Corner box, and 

depending on the direction it was drawn, the front applied face of the ladder base was drawn short 

and with a butt end instead of a miter end. 

5. Fixed a problem where the ladder base ties could be drawn too long by 1” in certain multi-box 

cabinet configurations involving corner boxes. 

6. Removed a redundant and non-functional default from the CabWriter Settings dialog box Face 

Frame tab. Blind Corner Mid Stile is not needed; its functionality is provided by Drawer Mid Stile. 

7. CabWriter allows users to save and open defaults to a file, which is very powerful. These files can be 

shared by simply emailing them to someone or receiving them in the email. There are two potential 

and serious problems with this: first those files can be corrupted since they are merely text files.; 

second they can become obsolete if they were generated on an older version of CabWriter and 



defaults were added, deleted or names changed since. So CabWriter now has a registry of valid 

defaults. This registry is created when a user opens a CabWriter project with the Create Project tool 

or uses the Re-Load Factory Settings tool. When a file is saved it checks for illegal default names and 

blank defaults. A message informs the user to check for and correct blanks in the CabWriter Settings 

tabs. When a file is opened and a blank is read in it will also display in the CabWriter Settings tabs. 

 

In future releases we will add more checks to these files to help assure that they don’t create 

problems and frustration for the user. However, the user should always visually check the CabWriter 

Settings tabs to be sure there are no missing or incorrect defaults. 

  



Changes in CabWriter Version 2.0.0 Beta 11-27-2017 

New Functionality 

1. Completed the frameless end panel inclusion; i.e. End Sheet(s), End Panels(s) and End Opening(s) 

are now drawn whether or not their end stiles are drawn. If their end stiles are not drawn the front 

edge of the end sheet, end panel or end opening will extend to the face plane for the door and 

drawer fronts. See example of frameless below. 

 

 

Note: When an End Opening is created in a cabinet with End Opening Stile(s) drawn the material 

type and name is the same as the Carcass. When an End Opening is created in a cabinet with End 

Opening Stile(s) NOT drawn the material type and name is the same as the End Panel. 

 

2. When creating a CabWriter project with the Create Project tool, a project name is assigned and will 

appear in the Project Name field of the Project tab. This name can be changed at any time after 

creating a CabWriter project; simply change it in the Project Name field. 



3. The menu Extensions > CabWriter > View License and Check for Updates now includes a Licensed 

Version (formerly just Version)field and an Installed Version field. Notice in the image below that the 

Licensed Version is 1.0.0, but the user has installed a beta test version that is newer than the 

Licensed Version. The message below no longer tells the user if the installed version is up to date or 

there is a newer on available. Rather it simply informs the user of the latest available version. 

 

4. Added two new defaults, one each to the Base Cabinets and Upper Cabinets tabs called Back Corner. 

They are dropdown options with the choices Angled and Squared. These defaults determine 

whether the back corner is constructed at a 45 degree angle or square. 

When Squared is selected for the Back Corner the angled Shelf Support is not drawn and the Shelf 

Support shelf holes are consequently not drawn. In their place shelf holes are drawn in the Left and 

Right Back. See examples below. 

 

  



 

 

Note the shelf hole arrangement and the shelf design 

and placement. The L-shaped shelves are drawn by 

CabWriter. The straight shelves, shown right,  were 

simply L-shaped shelves modified in Component Edit 

mode and one of them rotated. The Diagonal Corner 

cabinet (box) is now also available with a square corner. 

Note in these images that CabWriter provides two 

columns of shelf holes in the backs of the cabinet that 

match the shelf holes in the box sides. This is so you can 

have standard L-shaped or straight shelves (image on 

right).  

 

 

 

 



5.  

 

Fixes 

1. Fixed a problem with diagonal corner cabinet. If the Cabinet Style was Frameless and the End Stiles 

were drawn, the door did not position correctly. 

2. Fixed the Door/Drawer Panel Profile raised.skp file, which was cause an error because it contained a 

construction line. 

3. Fixed a problem with Diagonal Corner and Lazy Susan cabinet where the End Opening Fillers were 

not drawn correctly. 

4. Fixed a problem with using Make CabWriter Component to add a Mid Stile to a Face Frame, which 

resulted in a SketchUp error message. The CutList Bridge defaults for Doors and Drawers were not 

loaded. 

5. Fixed the Make CabWriter Component dialog box so that the Description and Instance Name input 

fields now permits pasting into them. 

6. Fixed a problem where, when bottom trim is drawn, on a Lazy Susan cabinet the trim was not placed 

correctly. 

  



Changes in CabWriter Version 2.0.0 Beta 11-7-2017 

New Functionality 

1. Added and changed some defaults on the Carcass tab of CabWriter Settings in the General, Back and 

Joinery sections. The General section is new and has one default called Top/Bottom/Stretcher 

Recess. This default is implemented and works as described in 2 below. The Back and Joinery 

sections appear in the Carcass tab but are not yet implemented. These defaults will become 

important and active when we implement dado, rabbet and packet joinery. 

 

 
 

2. The default called Top/Bottom/Stretcher Recess in the General section of the Carcass tab permits 

the recessing of the top, bottom, top stretchers, mid stretchers and any fixed shelves. The default is 

0”. 

 

3. Renamed the Re-Name Component tool to Make CabWriter Component, changed its icon from  

to  (which I don’t like but will change again later) and also changed its functionality. 

In the past, in order to add a custom component to a CabWriter cabinet you first had to model the 

component in primitives using native SketchUp tools, select all the primitives and then use 



SketchUp’s Make Component  tool to make a SketchUp component. Next you used the Re-Name 

Component  tool to turn the SketchUp component into a CabWriter Component. 

 

I have eliminated one step in this process. To add a custom component to a CabWriter cabinet you 

first model the component in primitives using native SketchUp tools, select all the primitives and 

then use the Make CabWriter Component  tool to make a CabWriter Component. This allows 

you to go directly from selected primitives to a CabWriter Component. 

 

You can still select a component and use the Make CabWriter Component  tool to turn a 

SketchUp component into a CabWriter component, or select a CabWriter component and use the 

Make CabWriter Component  tool to rename or change attributes of the component. However, 

the restrictions are that the selection you pass to the Make CabWriter Component tool must either 

be all primitives or one component, and that component’s definition name must be unique (not 

currently in the model’s definition list). Primitives plus anything else or more than one component 

will result in an error message. 

If the user selection is primitives when using the Make CabWriter Component  tool the Make 

CabWriter Component dialog box will look similar to the following: 

 

 

However, if the user’s selection is a CabWriter component prior to selecting Make CabWriter 

Component tool it will look similar to this: 

 



 

Lastly, if the user’s selection is a SketchUp component (non-CabWriter component) prior to selecting 

the Make CabWriter Component tool it will look similar to this: 

 

 

In all cases the component can be changed to a CabWriter component or a CabWriter component 

renamed. This change was made to streamline the creating of a CabWriter component. There will be 

future changes that will further enhance and streamline the process. 



 

In addition to the look and name change of this tool, a lot of functionality has changed. There are 

three sections to this dialog box. The first section, Current Component Instance Names, simply tells 

the user what the current definition name and instance name are. These fields will not change until 

a successful execution of this tool is completed. Note, for this reason they are grayed out and 

cannot be changed. 

 

The second section, Changes to Component Instance Names & Protection, is where the user will 

make all the changes desired before execution the tool with the OK button. Inside this section some 

fields are labeled in blue italics, one in red italics and the rest are normal black. The blue italics fields 

contain test that will be assembled into a component definition name and displayed in the third 

section in the field called Definition Name. This will happen in real time so that you will see the 

changes as you make them. The red italics label, Sub-Type, is a selection from a drop down list that 

will change as a function of the choice made in the blue italics Component Type drop down. The 

Sub-Type field is not part of the definition name, but rather a classification of a Component Type, 

which is used only to determine the appropriate information to write in the component’s CutList 

Bridge attributes. 

 

Starting at the top of the second section the Cabinet Number field is where the user supplies the 

cabinet number that this new CabWriter component will be assigned. It must be a valid cabinet 

number and that cabinet must currently exist in the model. The user can type the number into the 

field without regard to capitalization; CabWriter will correct for capitalization. But the cabinet 

number must start with the letter C followed by a non-zero integer and end in either U or L. 

 

Next is Component Type. The user must choose a component type from the drop down; blank is not 

a component type. If the Component Type contains the # symbol, the user must then input a non-

zero integer into the unlabeled field next to Component Type. If the selected Component Type does 

not contain a # symbol the unlabeled field will be grayed out. 

 

Next is the Sub-Type field. This field will change each time a Component Type selection is made. The 

user can select blank or any item on the list. If blank is chosen the new component will have CutList 

Bridge attributes initialized to a Milled Part(s) with blank fields except for the correctly assigned Sub-

Assembly and CabWriter Protection. If an item other than blank is chosen the component will have 

correctly assigned attributes based on the current CabWriter defaults, Sub-Assembly and CabWriter 

Protection. 

 

The next field, Description, is where the user supplies the description part of the definition name. 

The description part is the part that comes after the cabinet number and component type. The user 

does not supply the space between the cabinet number/component type and the description; 

CabWriter automatically inserts that. 

The Instance Name field is where the user supplies the new component’s instance name. 

 



To provide CabWriter protection for this new component the user chooses Yes from the Set 

CabWriter Protection? Drop down; or No if no CabWriter protection is requested. 

 

Lastly, the third section, New CabWriter Component Instance Names & Protection, show the 

compiled results from changes made in the Changes to Component Instance Names & Protection 

section. This is what will be written to the new component along with the appropriate CutList Bridge 

attributes when the user clicks on the OK button. The user should carefully inspect this before doing 

so. In addition, once the operation is complete it would be wise for the user to select the new part 

and examine its attributes with the Extended Entity Info dialog box. 

 

Choosing the Cancel button will return the selection to its original state. 

 

NOTE: The Make CabWriter Component cannot be used to change the Instance Name of a normal or 

CabWriter component. Use the Entity Info dialog box to change an Instance Name. 

4. Changed the name of the dialog box opened by the View License and Check for Updates command 

in the Extensions > CabWriter menu. Changed it from Active CabWriter License to View License and 

Check for Updates. 

5. A major functionality addition is the ability to include cope & stick door, drawer, end panel and back 

panel styles. This functionality is only available to users with SketchUp Pro licenses, and at the 

moment only three coped styles are available. We will add many more by the time Version 2.0.0 is 

released. 



 

 

In the above image notice that the Base and Upper Doors Style sections have changed significantly; 

there are now five defaults in each section. Here is there meaning: 

➢ Door Face Style – Drop down options are: 

▪ Frame and Panel – door fronts will be constructed as frame and panel unless a door is 

too narrow or too short in which case they will be drawn as a slab. 

▪ Slab – Doors will be constructed as a Slab. 

➢ Frame & Panel Style – Drop down options are: 

▪ Basic Frame and Panel – door fronts will be constructed as a basic frame and panel. 

▪ Profile Cope & Stick – door fronts will be constructed by cope & stick profiles defined by 

the next three defaults. 

➢ Frame Outside Edge Profile – Typically a router bit profile used to cut the outside edge of 

the frame. Drop down options at the moment are: 

▪ Basic – this is a straight edge profile. 

▪ Bevel 45 – This is an edge profile with a 45 degree chamfer on the front edge. 

➢ Frame Inside Edge Profile – Typically a router bit profile used to cut the inside edge of the 

frame. Drop down options at the moment are: 



▪ Basic – this is a straight edge profile. 

▪ Bevel 45 – This is an edge profile with a 45 degree chamfer on the front edge. 

▪ Ogee – This is an edge profile with an ogee curve on the front edge. 

➢ Panel Edge Profile - Typically a router or shaper bit profile used to cut the outside perimeter 

of the panel. Drop down options at the moment are: 

▪ Basic – this is a straight edge profile. 

▪ Raised - This is an edge profile with a shallow chamfer and a raised panel. 

▪ Curved Raised - This is an edge profile with a shallow Bezier curve and a raised panel. 

 

You will not find these five defaults on the Drawers or Panels tabs. It is assumed that drawer fronts, if 

they are not to be Frame and Panel will be a Slab construction. If drawers are to be a Frame and Panel 

construction, they will use the same styles as the doors specified by the Doors tab. Hence on the 

Drawers tab for Drawer Face Style the only drop down options are: Frame and Panel with edge styles 

defined on the Doors tab; and Slab. 

 

In a similar rationale, it is assumed that End Panels and Back Panels will use a similar frame and panel 

style to the doors defined by the Doors tab or a basic frame and panel. Hence the End Panel Style and 

Back Panel Style drop downs only have two options: Same as Door; and Basic Frame and Panel. If you 

want a Slab constructed End Panel, you can choose that by specifying an End Sheet stile at the end of 

the cabinet. At the moment, if you want a Slab constructed back panel you can draw the component 

with native SketchUp tools and then use the Make CabWriter Component tool. 

Here are two examples of cope and stick finishes. 

  



  



 

 



 

6. Changed the default value for Draw Alignment Slot on bot Base and Upper Cabinet tabs to No. 

7. CabWriter now draws End Sheet(s) when Sheet Stile Draw? Checkbox is unchecked; i.e. End Sheet(s) 

are drawn whether the Sheet Stile is checked or unchecked. If Sheet Stile Draw? Is unchecked the 

End Sheet will extend to the same plane as the door/drawer fronts front plane. This change only 

affects Sheet Stiles. In the next beta release it will work the same way for End Panel Stiles and 

Opening Stiles. This change is meant to benefit frameless designs. 



 

 

 

 

 

Fixes 

1. Fixed a problem where the user could not use any of the CutList Bridge File commands on a non-

CabWriter project. 

2. Fixed a problem with the Create a Back Panel tool. Back panels with larger than two panels resulted 

in the last panel being a width stretching from the beginning of the second panel to the end of the 

last panel. The user couldn’t visually see this on the basic panel type unless they looked at its 

dimensions or move it out of the frame and panel assembly. 
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